tmuxを2.2にしたらエラーがでたので対応した

tmux 2.2 にアップデートしたらエラーが出るようになったので対応したメモ。


環境

  • OS: Mac OSX El Capitan 10.11.5
  • tmux: 2.2

2.2にアップデートしたtmuxを起動するとエラー表示される

Terminal
1
2
$ tmux
/Users/nanigashi/.tmux.conf:1: unknown option: utf8

changelog を見てみる

changelog を見ると以下のように書いてあった。

  • UTF8 detection how happens automatically if the client supports it, hence
    the:

    mouse-utf8
    utf8

    options has been removed.

 

自動でutf8を検出して設定するようにしたからオプションは削除したということらしい。

対応内容

.tmux.conf からオプションを削除する。

.tmux.conf
1
setw -g utf8 on #=> 削除する

以上です。

© 2018 磁力式駆動 All Rights Reserved.
Theme by hiero